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Chapter 1 
Introduction 

This chapter introduces you to Alphapack. It covers: 
 About Alphapack 
 About this guide 
 Technical support 

About Alphapack 
Alphapack is designed to expedite the way in which you (the Tax User) collect the 
data required from finance professionals (referred to throughout this guide as 
Accounts Users) in order to generate tax computations and returns. 
You can customise the statements each Alphapack should contain and you can 
choose to hide a number of columns within certain statements. 
Once an Alphapack is ready you publish it for use by the Accounts User who is 
notified by email that the Alphapack is ready. The Accounts User receives a 
system-generated user id and password. 
Accounts Users download and install the Alphapack software and can then open 
and complete the Alphapack before signing it off and sending an email 
notification to you the Tax User.  
Every time the Accounts User saves the Alphapack while online, the Alphapack is 
saved directly back to your Alphatax database on your network. As a result, 
whenever an Alphapack is saved, you can review it and give the Accounts User 
advice on any problems they may have. 
Once an Alphapack has been signed off, you can make changes within the 
Alphapack before importing it back to Alphatax or re-publishing it if you require 
further information from your client. 
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About this guide 
This document guides you through the process of preparing an Alphapack: 
 Creating an Alphapack (Chapter 2) 
 Preparing an Alphapack (Chapter 3) 
 Transferring the collected data back into Alphatax (Chapter 4) 

Technical Support 
We provide a technical support help desk for users requiring assistance with the 
Alphatax and Alphapack software. The help desk is manned by qualified 
professionals experienced in both tax practice and IT applications.  
The help desk can be contacted by telephone between the hours of 9.00 am and 
5.30 pm, Monday to Friday excluding public holidays. If a consultant is not 
available to speak with you immediately, every effort will be made to return your 
call within one hour.  
The technical support team can be contacted by telephone or Email as follows: 
Tel: +44 (0) 1784 410229 
Email: support@taxcomputersystems.com 
Note. We recommend that you use the E-mail Support option from the Help menu 
(in both Alphatax and Alphapack) to send copies of the computation and the 
Alphapack directly to Support. 
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Chapter 2 
Creating an Alphapack 

This chapter gives you the information you need to create an Alphapack.  

Preparing the computation 
1. Check that the Alphatax document contains the accounting period for 

which you wish to create an Alphapack. If the accounting period does not 
already exist you will need to add it first. 

2. Check that the company name is correctly defined in the Standing data 
Input statement. If not, enter the name and then save the document. Avoid 
long names and non-alphabetical characters, particularly the ":" character. 

3. Check that trades have been correctly set up in the computation before 
export as you cannot create these within the Alphapack. 

4. Where Accounts Analysis is in use, ensure that the required settings are 
defined in the Accounts analysis options Input statement as there are no 
configuration options within the Alphapack itself. 

5. Ensure that any Freeformats sent out in multiple Alphapacks are 
Divisional Freeformats. This will allow values to be aggregated when 
importing multiple Alphapacks. Freeformats will only be exported to an 
Alphapack if marked as divisional or assigned to the Alphapack. For 
details, see page 10. 

6. Check that any relevant data entered is assigned to the Alphapack or 
Alphapacks (if there are multiple Alphapacks for the computation). For 
details, see page 6. 
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Setting up Alphapacks and assigning data 
Before you can export company data to an Alphapack, you must set up details of 
the recipient. 
Select Alphapack from the Compliance process section on the Contents list. 
Enter the recipient’s name and email address.  
Note. Any email address entered here will be displayed automatically in the 
Alphapack Email Details statement and the Publish dialog within the Alphapack 
(see page 21).  
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Single Alphapacks 
In most cases, only one Alphapack will be created for a computation period.  In 
this case: 
 Only one row is available in the Alphapack statement and you cannot add new 

rows 

 All company level brought forward data is exported to the Alphapack 
 All company level data (e.g. Profit & loss account and Balance sheet data) is 

exported to the Alphapack 
 Brought forward values exported to the Alphapack can be edited in the first 

period but not thereafter 

 Items assigned to the Alphapack will have their brought forward values 
exported to the Alphapack. 

Assigning data to single Alphapacks 
Use the right mouse click menu to assign data or statements to the Alphapack(s). 
Normally assign data to the Alphapack (Alphapack Sample in the example 
below). If you choose <All divisions>, any item description (Adjustment 1 to 3 in 
the example below) will not be editable within the Alphapack. 

 
Note. Where items are not assigned, a new Assigning items dialog is displayed 
when you start to create the Alphapack. For details, see page 11. 
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Multiple Alphapacks  
Set the Is more than one Alphapack required for the period? field to Yes on 
the Alphapack Input statement within the Compliance process section of the 
Alphatax Contents tree before creating the Alphapack(s). 

 
 Multiple rows are available and multiple Alphapacks can be created (use insert 

to add extra rows if required) 
 No brought forward items are assigned to an Alphapack unless at item-level 

where the item is specifically assigned to the Alphapack 
 No company level data is exported to the Alphapack 

 Items assigned to the Alphapack will have their brought forward values 
exported to the Alphapack 

 All brought forward values will be blank editable fields in the Alphapack 
regardless of the period. This will enable users to enter data appropriate for the 
area of business. This data will not be imported into Alphatax and will not 
therefore affect the computation. It will be retained for viewing in the 
Alphapack history window. 
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Assigning data to multiple Alphapack(s) 
Assign data to individual Alphapacks (APACK 1 and APACK 2) in the example 
below or to <All divsisions> if the data applies to multiple Alphapacks. In this 
case, note that the item description (Adjustment 1 in the example below) will not 
be editable within the Alphapacks. 

 
Note. Where items are not assigned, a new Assigning items dialog is displayed 
when you start to create the Alphapack. For details, see page 11. 

Tracking assigned data 
Once data has been imported, you can track entries for each division: 
 For numerical entries that have been aggregated, use the right mouse click 

button to see how the figures are derived from each division 
 For other entries, use the right mouse click button to see which division 

entered the data 
To ensure that the process works smoothly: 
 Ensure that any Freeformats sent out in Alphapacks are Divisional 

Freeformats. This will allow values to be aggregated when importing multiple 
Alphapacks.  
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Divisional Freeformats 
Note. Divisional Freeformats are automatically assigned to <All divisions> and 
are thus available in all Alphapacks. 
1. Within Alphatax, create and name the Freeformat and define the layout as 

required. 
2. Ensure that the Freeformat has duplicating rows so that users of the Alphapack 

will be able to insert rows. To do this: 

 Highlight the cell and then select Properties from the Cell or right mouse-
click menu. 

 Set Column A as Input Text style. 
 Set the remaining columns that you wish to define as Input Number or 

Input Date style, etc.  
Note. You can set Column A as General style if Column B is set to Input Text 
style. If the Input Text cell is not in column A, all columns to the left of that cell 
must be input General and cannot contain any values. 
3. Then: 

 Choose Properties from the Statement or right mouse click menu 
 Select the Protection tab in the Statement properties dialog 
 Select the Division radio button. 
 Click Apply 

Note. You can check the Apply to ALL free format statements if you wish all of 
your Freeformat statements to appear in all your Alphapacks (this also applies if 
you only have a single Alphapack). 
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Creating the Alphapack 
At the Alphapack Input statement, highlight the recipient for whom you are 
creating the Alphapack. 
From the right mouse click or Tools menu, choose Alphapack. The Alphapack 
dialog is displayed. 

 
Alphatax will store the Alphapack in the Enterprise database.  
When you are ready, choose the Create button.  

Unassigned items 
Where items in the computation have not been assigned, the following dialog is 
displayed. 
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Specify how you want the items assigned and choose Create to continue creating 
the Alphapack or Cancel if you want to return to the computation. 
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The new Alphapack 
Once the Export is complete, you are prompted to open the Alphapack. 
If you choose Yes, the Alphapack opens in a new window.   

 
Note. You can view the Alphapack at any time by selecting View from the 
Alphapack dialog for that Alphapack. 

After creating the Alphapack 
Reviewing the Alphapack 
Click the View button to review the Alphapack and make any changes before you 
publish it for use by the Accounts User. 

For guidance on preparing and publishing the Alphapack, refer to Chapter 3. 

Company document locked 
The company document is locked and cannot be edited in Alphatax until the 
exported Alphapack(s) are re-imported or cleared.  
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Exporting the Alphapack twice  
Once you have created the Alphapack, the Create button is disabled so that you 
cannot export it twice.  
However, you can click the Clear button if you want to start again. But note that 
the new Alphapack has a different GUID so users should be careful not to clear 
the export if the Alphapack has already been published to the client as this 
Alphapack will no longer be accepted by Alphatax and the Accounts User will no 
longer be able to access the Alphapack (their changes will be lost). 
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Chapter 3 
Preparing the Alphapack  

Once you have created and opened an Alphapack, you should prepare it for use by 
the Accounts User before publishing it so that it can be completed and signed off 
by the Accounts User. For details, refer to Completing Your Alphapack. 

Using the Alphapack desktop 
The Alphapack desktop is similar to the Alphatax desktop. To help ensure that 
you are always aware which application you are using, the title Alphapack 
appears in red on the Alphapack desktop. 
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You can work in three modes: 
 Design mode. Use this mode to prepare and customise the contents of the 

Alphapack. This is the default mode when you view the Alphapack. 
 Input mode. Use this mode to view the Alphapack exactly as it will appear to 

the Accounts User.  
 Report mode. Unlike in Alphatax there are no calculations in any of the 

reports present in Alphapack other than simple summations. It is purely a data 
view displaying only the statements that contain user-entered data. 

Preparing the Alphapack 
When you select to View the Alphapack from within Alphatax, the Alphapack 

desktop is displayed by default in Design mode with the Design mode icon 
highlighted. 
This mode enables you to enable or disable specific statements and to hide or 
display certain columns. 

To enable/disable sections and statements 
Highlight the statement in the Contents list 
Select Enable/Disable Entry from the right mouse click menu or use the space 
bar. 
A disabled section and/or statement is shown with a line across it when in Design 
mode. 
Disabled statements will not be visible to Accounts Users. 
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To hide or display columns within statements 
Columns that can be hidden are shown with a green tick  at the top of 
the column. To hide a column, click on the tick which changes to a red cross 

. Columns with a red cross will not be visible to Accounts Users. 

 

To switch to and from Input mode, press F5, click the Design mode  icon or 
choose Input or Design mode from the View menu. 
Note. To preview your customised Administrations statements and Contents tree 
as it will appear to the Accounts User, switch to Input mode. 

To switch to and from Report mode, press F7, click the Report mode  icon or 
choose Report mode from the View menu. 
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Customised Administration statements 
You can edit any of the customised statements that may be listed in the 
Administration section of the Contents tree. 
Note. Customised Administration statements are not imported back into Alphatax. 

 
Note. For the Accounts User (and in Input mode), these statements work in the 
same way as standard Input statements. Fields marked as General on the 
statement are protected and data can only be entered in cells defined by the Tax 
User (e.g. numerical/textual/date inputs). To preview the statement as the 
Accounts User, use Input mode. 
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Freeformat statements 
You can create Freeformat statements to collect information not included in the 
standard Alphapack statements. 

Working in Input mode 
In Input mode, you see the Alphapack exactly as it will appear to the recipient. 
Disabled statements and hidden columns cannot be detected. 

 

To switch to and from Design mode, press F5, click the Design mode  icon or 
choose Design mode from the View menu. 

To switch to and from Report mode, press F7, click the Report mode  icon or 
choose Report mode from the View menu. 
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To generate or select configuration template files 
Where the structure of an Alphapack is likely to be used again and again, you can 
save the Alphapack as a template to be applied to other Alphapacks or other 
periods. This will include the same statements and columns, where these have 
been enabled or disabled. 
Use the Tools menu to: 
Generate Company Configuration Template – this saves the current Alphapack 
as a template for future use. Note that any data entered on Freeformat statements 
will not be saved in the template. 
Select Company Configuration Template – this selects an existing 
configuration template to apply to this Alphapack year on year or to create 
multiple identical Alphapacks. 
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Publishing the Alphapack 
Once you have prepared the statements to include with the Alphapack, you can 
publish the Alphapack to the Accounts User. 
First set up email details in the Alphapack e-mail details Input statement. 

 
Note. The address of the Accounts User will be taken from the Alphapack Input 
statement in the Compliance process section of the Alphatax Contents tree if the 
email address was entered there. 
Then select choose Publish from the Tools menu. 
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Note. If you publish another Alphapack to the same user in future, the same 
credentials will be retrieved and used. 
Email notifications can be created automatically in order to supply the email 
address and password  the Accounts User should use to log on to Alphapack.  
Note. Email notifications may also contain a link to a page where the Alphapack 
software can be downloaded by the Accounts User together with guidance on 
completing the Alphapack. This is controlled by a setting in the tcslbase.ini file. 

Review cycles 
Once you have sent the Alphapack publish notification to your client, you can 
review it at any time but you cannot edit data until the client has signed it off. 
Until this has happened the pack will have the status [Published]. This can be 
useful if your client has any queries or problems. 
Once the pack has been signed off by the Accounts User, the status will change to 
[Signed Off] and you can edit the Alphapack or import it back to Alphatax.  
Note The Accounts User may send you an email notification on sign off. 
If you are not happy with the content, you can republish it to the Accounts User 
and repeat this cycle as many times as required prior to importing to Alphatax. 
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Monitoring the Alphapack 
Once you have published the Alphapack and the Accounts User has started to 
work on it, you can monitor the Alphapack status within Alphatax by viewing the 
Alphapack Input statement and then selecting Refresh Alphapack status from 
the right mouse click menu.  

 
A description of each status is given below: 
 Created. The Alphapack has been created but not yet published to the recipient 
 Cleared. You have cleared the import/export status of the Alphapack so that 

you can recreate it 
 Published. The Alphapack has been published to the recipient 
 Signed off. The Alphapack has been signed off by the recipient. You can now 

work on it. 
 Imported. The Alphapack data has been imported back to Alphatax for this 

computation 

Alphapack history 
The Alphapack history window maintains a log of all major events that have taken 
place for that particular Alphapack (e.g. publish, signoff, clear and import). This 
allows you to maintain a read-only audit trail of these events for each Alphapack, 
which can be viewed at any time. 
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For each Alphapack, the window shows the Cycle number. This increases each 
time the Alphapack is created for a period or cleared and then re-created.  
The window also shows Date and time last saved and the Account User's email 
where the action was performed by the Accounts User. 
Select the View button to view the Alphapack in read-only mode at any time. 
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Chapter 4 
Transferring Data Back to Alphatax  

Once the client has signed off the Alphapack and you are happy with the 
document you import it back into Alphatax via the Alphatax Alphapack dialog. 
Click the Import button to import the Alphapack into Alphatax. 
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Signing off 
You cannot import an Alphapack that has not already been signed off. The 
Alphapack will normally be signed off by the Accounts User but in exceptional 
circumstances the Tax User is enabled to sign off the Alphapack. 
This may be required for example if the Accounts User leaves their job, is ill or on 
holiday.   
In this case, while in Input mode, choose Sign off from the Tools menu. 

After importing the Alphapack 
1. Check all of the information has been transferred correctly from the 

Alphapack into the Alphatax computation. 
2. Where necessary, review and enter into Alphatax the tax treatment of 

items (e.g. expenses disallowed, amounts taxable, capital expenditure 
eligible for allowances). 

3. Review the draft computation in accordance with your normal procedures. 
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Appendix A – Configuring Alphapack 

A configuration module is available for use which allows you to create a standard 
Alphapack template for use in your organisation. 

Opening the Configuration module 
Navigate to the folder where you installed Alphatax (usually C:\Program 
Files\TCSL\TCSL Alphatax). 
Double-click on the tcslapmgr.exe file. 
The TCSL Alphapack Configuration Tool will open up. 
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Configuring the Alphapack 
Make changes to the Alphapack configuration exactly as you would any other 
Alphapack. 
Enable or disable statements and columns as required. 
Note. You cannot enter data in standard Input statements or add Freeformats. The 
only exception to this is any customised Administration statements – see below. 

Customised Administration statements 
The configuration tool enables you to create new customised Administration 
statements. These work as standard Input statements for the Accounts User. 
Within the Administration section of the Contents tree, select Insert: Statement 
from the right mouse click menu. 

 
Define headings and columns as for a Freeformat statement. 
Note. You can also edit and delete any existing customised Administration 
statements. 
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Saving the configuration 
When you have configured the Alphapack as required, choose Save from the File 
menu. 
This document will become the default Alphapack template for all Alphapacks 
created from the same location as the where the configuration module is run. 
Whenever an Alphapack is first created, it will have the same statements 
(including any customised Administration statements) and the same columns 
enabled or disabled as you define in the configuration module. 
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